Slow delivery of phishing simulations using SMTP

Incident Report for Secure Practice

Resolved

All systems working as normal
Posted Jul 13, 2026 - 12:12 CEST

Identified

SMTP delivery of phishing simulations is slow for some customers
Posted Jul 13, 2026 - 10:46 CEST
This incident affected: Phishing simulator (Phishing emails [SMTP]).