Slow delivery of phishing simulations

Incident Report for Secure Practice

Resolved

all systems normal
Posted Jun 01, 2026 - 00:59 CEST

Monitoring

Queues are draining
Posted May 31, 2026 - 18:13 CEST

Investigating

We are yet again experiencing slow delivery of phishing simulations for some of our customers
Posted May 28, 2026 - 08:25 CEST
This incident affected: Phishing simulator (Phishing emails).