MailRisk closes automatically

Incident Report for Secure Practice

Update

Web client seems to be functioning. Outlook desktop (new) on Windows still has problems.
Posted Oct 24, 2025 - 12:55 CEST

Investigating

Some users are reporting that MailRisk is closing itself. The problem is pinpointed to the web client and the new client on Windows platforms.
Posted Oct 24, 2025 - 11:15 CEST
This incident affects: MailRisk (MailRisk add-in (Outlook)).