All outgoing queues are flushed and all systems working as normal
Posted Apr 16, 2026 - 08:46 CEST
Identified
We have identified the issue, and are working with the vendor to mitigate it.
Posted Apr 15, 2026 - 14:52 CEST
Investigating
Some customers have problems sending phishing simulations. The problem is at the vendor of the email hosting for those affected vendors. We are working with the vendor to try to resolve this.
Posted Apr 15, 2026 - 13:20 CEST
This incident affected: Phishing simulator (Phishing emails).