Slow delivery of phishing simulations

Incident Report for Secure Practice

Resolved

All queues are running normal
Posted May 13, 2026 - 13:26 CEST

Investigating

Delivery of phishing simulatilons is slow at the moment and for some customers the time to deliver is several hours. We are investigating and monitoring the situation.
Posted May 13, 2026 - 09:39 CEST
This incident affected: Phishing simulator (Phishing emails).