MailRisk not working for some cusomers

Incident Report for Secure Practice AS

Postmortem

Postmortem

Root cause identified to be related to planned changes in Exchange Web Service and Secure Practice were not able to identify the impact of this for our customers.

Early identification of possible impacted customers and mitigation of those who could be migrated to modern authentication limited this incident to a small number of customers.

As both Exchange Web Services and Exchange 2016 and 2019 versions will be End Of Life 2025-10-14, customers still on this platform are advised to plan for migrations to supported products as soon as possible.

External information:

Posted Mar 24, 2025 - 14:01 CET

Resolved

All systems are operational and working.
Posted Mar 24, 2025 - 13:09 CET

Monitoring

A fix for customers in hybrid setups has been deployed. We are monitoring the effect of this.
Posted Mar 24, 2025 - 11:54 CET

Update

We are still working on a fix
Posted Mar 24, 2025 - 10:15 CET

Identified

The error is related to authentication and Exchange Web Services (EWS).

Customers having migrated to Exchange Online without updating mailbox platform are affected. Fix for this scenario is to update this setting.

Customers having a hybrid platform could use the old an on prem Exchange as EWS would also authenticate their users in O365. We are working on a fix to hopefully be able to route authentication the correct direction depending on where the user are being hosted. In this scenario, we still have no fix.
Posted Mar 21, 2025 - 14:39 CET

Investigating

We are currently investigating a problem that seems related to on prem Exchange and authentication.
Posted Mar 21, 2025 - 14:14 CET
This incident affected: MailRisk (MailRisk add-in).