We have finally identified and remediated an issue with delayed processing of emails for MailRisk analysis. Again, we will continue to monitor, and let us know if you notice any further inconsistencies. However, with this, we conclude the incident as resolved.
Posted Sep 12, 2025 - 12:21 CEST
Monitoring
We have completed the relocation of services and are monitoring the situation to verify everything works as it should - please contact support if you notice any inconsistencies. Thank you for your patience, and we sincerely apologize for any inconvenience.
Posted Sep 12, 2025 - 10:33 CEST
Update
We are making progress on restoring services, by switching to a failover location instead of waiting for Microsoft Azure to fully restore their services. We expect services to be fully operational within the hour, or sooner.
Posted Sep 12, 2025 - 10:18 CEST
Identified
Microsoft Azure reports that some of the affected services have been restored. They are reviewing hardware and monitoring the situation as they bring remaining services back up.
Posted Sep 12, 2025 - 09:13 CEST
Update
We are continuing to investigate this issue.
Posted Sep 12, 2025 - 07:47 CEST
Investigating
Due to a datacenter issue at Microsoft Azure with a failure on cooling systems, physical servers have been broadly powered off as a precautionary measure. As a consequence, our services are temporarily unavailable until cooling has been restored. We are currently assessing the situation, and awaiting more information from the datacenter provider.
Posted Sep 12, 2025 - 06:33 CEST
This incident affected: Phishing simulator (Landing pages and debriefing, Phishing emails), Authentication (Accounts, User synchronization (SCIM)), Portals (Administrator portals, Learning portal, Email notifications), and MailRisk (MailRisk add-in (Outlook), MailRisk API, MailRisk addon (Gmail)).