Slow delivery of phishing simulations

Incident Report for Secure Practice

Resolved

All systems working normal
Posted Jun 15, 2026 - 08:44 CEST

Investigating

We are experiencing some slow delivery of simulations for some customers.
Posted Jun 09, 2026 - 13:12 CEST
This incident affected: Phishing simulator (Phishing emails).