Slow delivery of phishing simulations

Incident Report for Secure Practice

Resolved

All simulations delivered
Posted Jun 05, 2026 - 09:59 CEST

Investigating

We are experiencing slow delivery of phishing simulations for some customers.
Posted Jun 04, 2026 - 15:09 CEST
This incident affected: Phishing simulator (Phishing emails).