Slow delivery of phishing simulations

Incident Report for Secure Practice

Resolved

All systems working normal
Posted Jul 02, 2026 - 23:56 CEST

Investigating

We are currently experiencing slow delivery of phishing simulations for some customers.
Posted Jul 02, 2026 - 08:42 CEST
This incident affected: Phishing simulator (Phishing emails [SMTP]).