Platform maintenance

Scheduled for Apr 4, 06:00 - 07:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 28, 2025 - 09:07 CET

Scheduled

Scheduled Routine Maintenance on hosting platforms
Posted Mar 28, 2025 - 09:03 CET
This scheduled maintenance affects: Phishing simulator (Landing pages and debriefing, Emails), Authentication (Accounts, SCIM), Portals (Administrator portals, Learning portal, Email notifications), and MailRisk (MailRisk add-in, MailRisk API, MailRisk addon).