Phishing simulation delays

Incident Report for Secure Practice

Resolved

All outgoing queues are now cleared and all phishing simulations delivered.
Posted May 07, 2026 - 09:30 CEST

Update

Still some simulations in queues. Slowly draining those queues now and situation should be normal within a couple of hours.
Posted May 07, 2026 - 07:45 CEST

Investigating

We are experiencing some delayed delivery on phishing simulations for some of our customer.
Posted May 06, 2026 - 13:46 CEST
This incident affected: Phishing simulator (Phishing emails).